#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)token[^"]+":[^"]+"([^.{\\}$"]+)"
Local $sString = "{" & @CRLF & _
""token.stdout_lines": [" & @CRLF & _
" "{"," & @CRLF & _
" "\t\"id\": \"08320829d85c7000\","," & @CRLF & _
" "\t\"description\": \"\","," & @CRLF & _
" "\t\"token\": \"zMiyCw7X6u_IjBpTbD1Nvt4eGk-dxBXWWOqRCgWh_KiYtp7AjD5mML5mBIEtApncBSXwU3QqexT_4VVmEv0WeA==\","," & @CRLF & _
" "\t\"status\": \"active\","," & @CRLF & _
" "\t\"userName\": \"telegraf\","," & @CRLF & _
" "\t\"userID\": \"0831cb0c68dc7000\","," & @CRLF & _
" "\t\"permissions\": ["," & @CRLF & _
" "\t\t\"read:orgs/ea37b04111f50748/buckets\","," & @CRLF & _
" "\t\t\"write:orgs/ea37b04111f50748/buckets\""," & @CRLF & _
" "\t]"," & @CRLF & _
" "}"" & @CRLF & _
"]" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")