const regex = /token[^"]+":[^"]+"([^.{\\}$"]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('token[^"]+":[^"]+"([^.{\\\\}$"]+)', 'gm')
const str = `{
"token.stdout_lines": [
"{",
"\\t\\"id\\": \\"08320829d85c7000\\",",
"\\t\\"description\\": \\"\\",",
"\\t\\"token\\": \\"zMiyCw7X6u_IjBpTbD1Nvt4eGk-dxBXWWOqRCgWh_KiYtp7AjD5mML5mBIEtApncBSXwU3QqexT_4VVmEv0WeA==\\",",
"\\t\\"status\\": \\"active\\",",
"\\t\\"userName\\": \\"telegraf\\",",
"\\t\\"userID\\": \\"0831cb0c68dc7000\\",",
"\\t\\"permissions\\": [",
"\\t\\t\\"read:orgs/ea37b04111f50748/buckets\\",",
"\\t\\t\\"write:orgs/ea37b04111f50748/buckets\\"",
"\\t]",
"}"
]
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}