// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)token[^"]+":[^"]+"([^.{\\}$"]+)"#).unwrap();
let string = "{
\"token.stdout_lines\": [
\"{\",
\"\\t\\\"id\\\": \\\"08320829d85c7000\\\",\",
\"\\t\\\"description\\\": \\\"\\\",\",
\"\\t\\\"token\\\": \\\"zMiyCw7X6u_IjBpTbD1Nvt4eGk-dxBXWWOqRCgWh_KiYtp7AjD5mML5mBIEtApncBSXwU3QqexT_4VVmEv0WeA==\\\",\",
\"\\t\\\"status\\\": \\\"active\\\",\",
\"\\t\\\"userName\\\": \\\"telegraf\\\",\",
\"\\t\\\"userID\\\": \\\"0831cb0c68dc7000\\\",\",
\"\\t\\\"permissions\\\": [\",
\"\\t\\t\\\"read:orgs/ea37b04111f50748/buckets\\\",\",
\"\\t\\t\\\"write:orgs/ea37b04111f50748/buckets\\\"\",
\"\\t]\",
\"}\"
]
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}