using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"token[^""]+"":[^""]+""([^.{\\}$""]+)";
string input = @"{
""token.stdout_lines"": [
""{"",
""\t\""id\"": \""08320829d85c7000\"","",
""\t\""description\"": \""\"","",
""\t\""token\"": \""zMiyCw7X6u_IjBpTbD1Nvt4eGk-dxBXWWOqRCgWh_KiYtp7AjD5mML5mBIEtApncBSXwU3QqexT_4VVmEv0WeA==\"","",
""\t\""status\"": \""active\"","",
""\t\""userName\"": \""telegraf\"","",
""\t\""userID\"": \""0831cb0c68dc7000\"","",
""\t\""permissions\"": ["",
""\t\t\""read:orgs/ea37b04111f50748/buckets\"","",
""\t\t\""write:orgs/ea37b04111f50748/buckets\"",
""\t]"",
""}""
]
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}