import Foundation
let pattern = #"token[^"]+":[^"]+"([^.{\\}$"]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"token.stdout_lines": [
"{",
"\t\"id\": \"08320829d85c7000\",",
"\t\"description\": \"\",",
"\t\"token\": \"zMiyCw7X6u_IjBpTbD1Nvt4eGk-dxBXWWOqRCgWh_KiYtp7AjD5mML5mBIEtApncBSXwU3QqexT_4VVmEv0WeA==\",",
"\t\"status\": \"active\",",
"\t\"userName\": \"telegraf\",",
"\t\"userID\": \"0831cb0c68dc7000\",",
"\t\"permissions\": [",
"\t\t\"read:orgs/ea37b04111f50748/buckets\",",
"\t\t\"write:orgs/ea37b04111f50748/buckets\"",
"\t]",
"}"
]
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)