package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)token[^"]+":[^"]+"([^.{\\}$"]+)`)
var str = `{
"token.stdout_lines": [
"{",
"\t\"id\": \"08320829d85c7000\",",
"\t\"description\": \"\",",
"\t\"token\": \"zMiyCw7X6u_IjBpTbD1Nvt4eGk-dxBXWWOqRCgWh_KiYtp7AjD5mML5mBIEtApncBSXwU3QqexT_4VVmEv0WeA==\",",
"\t\"status\": \"active\",",
"\t\"userName\": \"telegraf\",",
"\t\"userID\": \"0831cb0c68dc7000\",",
"\t\"permissions\": [",
"\t\t\"read:orgs/ea37b04111f50748/buckets\",",
"\t\t\"write:orgs/ea37b04111f50748/buckets\"",
"\t]",
"}"
]
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}