use strict;
my $str = '{
"token.stdout_lines": [
"{",
"\\t\\"id\\": \\"08320829d85c7000\\",",
"\\t\\"description\\": \\"\\",",
"\\t\\"token\\": \\"zMiyCw7X6u_IjBpTbD1Nvt4eGk-dxBXWWOqRCgWh_KiYtp7AjD5mML5mBIEtApncBSXwU3QqexT_4VVmEv0WeA==\\",",
"\\t\\"status\\": \\"active\\",",
"\\t\\"userName\\": \\"telegraf\\",",
"\\t\\"userID\\": \\"0831cb0c68dc7000\\",",
"\\t\\"permissions\\": [",
"\\t\\t\\"read:orgs/ea37b04111f50748/buckets\\",",
"\\t\\t\\"write:orgs/ea37b04111f50748/buckets\\"",
"\\t]",
"}"
]
}';
my $regex = qr/token[^"]+":[^"]+"([^.{\\}$"]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}