# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"token[^\"]+\":[^\"]+\"([^.{\\}$\"]+)"
test_str = ("{\n"
"\"token.stdout_lines\": [\n"
" \"{\",\n"
" \"\\t\\\"id\\\": \\\"08320829d85c7000\\\",\",\n"
" \"\\t\\\"description\\\": \\\"\\\",\",\n"
" \"\\t\\\"token\\\": \\\"zMiyCw7X6u_IjBpTbD1Nvt4eGk-dxBXWWOqRCgWh_KiYtp7AjD5mML5mBIEtApncBSXwU3QqexT_4VVmEv0WeA==\\\",\",\n"
" \"\\t\\\"status\\\": \\\"active\\\",\",\n"
" \"\\t\\\"userName\\\": \\\"telegraf\\\",\",\n"
" \"\\t\\\"userID\\\": \\\"0831cb0c68dc7000\\\",\",\n"
" \"\\t\\\"permissions\\\": [\",\n"
" \"\\t\\t\\\"read:orgs/ea37b04111f50748/buckets\\\",\",\n"
" \"\\t\\t\\\"write:orgs/ea37b04111f50748/buckets\\\"\",\n"
" \"\\t]\",\n"
" \"}\"\n"
"]\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.