# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-?\n\s+//g;t' <<< "So she refused to ex-
change the feather and the rock be-
cause she was afraid."