package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-?\n\s+`)
var str = `So she refused to ex-
change the feather and the rock be-
cause she was afraid.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}