using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-?\n\s+";
string substitution = @"";
string input = @"So she refused to ex-
change the feather and the rock be-
cause she was afraid.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}