re = /-?\n\s+/
str = 'So she refused to ex-
change the feather and the rock be-
cause she was afraid.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result