use strict;
my $str = 'So she refused to ex-
change the feather and the rock be-
cause she was afraid.';
my $regex = qr/-?\n\s+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";