#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "-?\n\s+"
Local $sString = "So she refused to ex-" & @CRLF & _
" change the feather and the rock be-" & @CRLF & _
" cause she was afraid."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)