import Foundation
let pattern = #"-?\n\s+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
So she refused to ex-
change the feather and the rock be-
cause she was afraid.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)