const regex = new RegExp('-?\\n\\s+', 'g')
const str = `So she refused to ex-
change the feather and the rock be-
cause she was afraid.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);