#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https\:\/\/\S+?\.domain.ru$"
Local $sString = "https://login1.domain.ru" & @CRLF & _
"https://login2.domain.ru" & @CRLF & _
"https://login3.domain.ru" & @CRLF & _
"https://login4.domain.ru" & @CRLF & _
"https://login4.domain1.ru" & @CRLF & _
"https://123.domain.ru" & @CRLF & _
"https://login-5.domain.ru" & @CRLF & _
"https://login4.1domain.ru" & @CRLF & _
"http://login.domain.ru" & @CRLF & _
"https://domain.ru" & @CRLF & _
"https://login99.domain.ru"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")