using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https\:\/\/\S+?\.domain.ru$";
string input = @"https://login1.domain.ru
https://login2.domain.ru
https://login3.domain.ru
https://login4.domain.ru
https://login4.domain1.ru
https://123.domain.ru
https://login-5.domain.ru
https://login4.1domain.ru
http://login.domain.ru
https://domain.ru
https://login99.domain.ru";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}