import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https\\:\\/\\/\\S+?\\.domain.ru$";
final String string = "https://login1.domain.ru\n"
+ "https://login2.domain.ru\n"
+ "https://login3.domain.ru\n"
+ "https://login4.domain.ru\n"
+ "https://login4.domain1.ru\n"
+ "https://123.domain.ru\n"
+ "https://login-5.domain.ru\n"
+ "https://login4.1domain.ru\n"
+ "http://login.domain.ru\n"
+ "https://domain.ru\n"
+ "https://login99.domain.ru";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}