import re
regex = re.compile(r"^https\:\/\/\S+?\.domain.ru$", flags=re.MULTILINE)
test_str = ("https://login1.domain.ru\n"
"https://login2.domain.ru\n"
"https://login3.domain.ru\n"
"https://login4.domain.ru\n"
"https://login4.domain1.ru\n"
"https://123.domain.ru\n"
"https://login-5.domain.ru\n"
"https://login4.1domain.ru\n"
"http://login.domain.ru\n"
"https://domain.ru\n"
"https://login99.domain.ru")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")