const regex = /^https\:\/\/\S+?\.domain.ru$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https\\:\\\/\\\/\\S+?\\.domain.ru$', 'gm')
const str = `https://login1.domain.ru
https://login2.domain.ru
https://login3.domain.ru
https://login4.domain.ru
https://login4.domain1.ru
https://123.domain.ru
https://login-5.domain.ru
https://login4.1domain.ru
http://login.domain.ru
https://domain.ru
https://login99.domain.ru`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}