#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:^|[^\\])(?:\\{2})*)\$0"
Local $sString = "Hello '$0'. '$0' becomes the World. This shall remain \$0. Extra: \\$0 is World, \$0 is escaped."
Local $sSubst = "$1World"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)