// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:^|[^\\])(?:\\{2})*)\$0").unwrap();
let string = "Hello '$0'. '$0' becomes the World. This shall remain \\$0. Extra: \\\\$0 is World, \\$0 is escaped.";
let substitution = "$1World";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}