using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:^|[^\\])(?:\\{2})*)\$0";
string substitution = @"$1World";
string input = @"Hello '$0'. '$0' becomes the World. This shall remain \$0. Extra: \\$0 is World, \$0 is escaped.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}