$re = '/((?:^|[^\\\\])(?:\\\\{2})*)\$0/m';
$str = 'Hello \'$0\'. \'$0\' becomes the World. This shall remain \\$0. Extra: \\\\$0 is World, \\$0 is escaped.';
$subst = "$1World";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;