import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:^|[^\\\\])(?:\\\\{2})*)\\$0";
final String string = "Hello '$0'. '$0' becomes the World. This shall remain \\$0. Extra: \\\\$0 is World, \\$0 is escaped.";
final String subst = "$1World";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}