use strict;
my $str = 'Hello \'$0\'. \'$0\' becomes the World. This shall remain \\$0. Extra: \\\\$0 is World, \\$0 is escaped.';
my $regex = qr/((?:^|[^\\])(?:\\{2})*)\$0/mp;
my $subst = '$1World';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";