#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)(.*)({LOOP}.*?{ENDLOOP})(.*)"
Local $sString = "{LOOP}" & @CRLF & _
" <span>Name %s</span>" & @CRLF & _
" {LOOP}" & @CRLF & _
" <option value="%SEL-VL%">%SEL-TXT%</option>" & @CRLF & _
" {ENDLOOP}" & @CRLF & _
"{ENDLOOP}"
Local $sSubst = "$1{LOOP INTERNO}$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)