$re = '/(.*)({LOOP}.*?{ENDLOOP})(.*)/ms';
$str = '{LOOP}
<span>Name %s</span>
{LOOP}
<option value="%SEL-VL%">%SEL-TXT%</option>
{ENDLOOP}
{ENDLOOP}';
$subst = "$1{LOOP INTERNO}$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;