import Foundation
let pattern = #"(.*)({LOOP}.*?{ENDLOOP})(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
{LOOP}
<span>Name %s</span>
{LOOP}
<option value="%SEL-VL%">%SEL-TXT%</option>
{ENDLOOP}
{ENDLOOP}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1{LOOP INTERNO}$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)