import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(\\{LOOP\\}.*?\\{ENDLOOP\\})(.*)";
final String string = "{LOOP}\n"
+ " <span>Name %s</span>\n"
+ " {LOOP}\n"
+ " <option value=\"%SEL-VL%\">%SEL-TXT%</option>\n"
+ " {ENDLOOP}\n"
+ "{ENDLOOP}";
final String subst = "$1{LOOP INTERNO}$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}