use strict;
my $str = '{LOOP}
<span>Name %s</span>
{LOOP}
<option value="%SEL-VL%">%SEL-TXT%</option>
{ENDLOOP}
{ENDLOOP}';
my $regex = qr/(.*)({LOOP}.*?{ENDLOOP})(.*)/msp;
my $subst = '$1{LOOP INTERNO}$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";