re = /(.*)({LOOP}.*?{ENDLOOP})(.*)/m
str = '{LOOP}
<span>Name %s</span>
{LOOP}
<option value="%SEL-VL%">%SEL-TXT%</option>
{ENDLOOP}
{ENDLOOP}'
subst = '$1{LOOP INTERNO}$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result