package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(.*)({LOOP}.*?{ENDLOOP})(.*)`)
var str = `{LOOP}
<span>Name %s</span>
{LOOP}
<option value="%SEL-VL%">%SEL-TXT%</option>
{ENDLOOP}
{ENDLOOP}`
var substitution = "$1{LOOP INTERNO}$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}