package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\[|\{)(im|tm|tv)db(?:id)?-(?:tt)?(\d+)(?:\]|\})`)
var str = `{imdb-tt0114746}
{tmdb-60948}
{tvdb-82}
[imdbid-tt0083658]
[tvdbid-356155]`
var substitution = "$1db $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}