$re = '/(?:\[|\{)(im|tm|tv)db(?:id)?-(?:tt)?(\d+)(?:\]|\})/m';
$str = '{imdb-tt0114746}
{tmdb-60948}
{tvdb-82}
[imdbid-tt0083658]
[tvdbid-356155]';
$subst = "$1db $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;