use strict;
my $str = '{imdb-tt0114746}
{tmdb-60948}
{tvdb-82}
[imdbid-tt0083658]
[tvdbid-356155]';
my $regex = qr/(?:\[|\{)(im|tm|tv)db(?:id)?-(?:tt)?(\d+)(?:\]|\})/mp;
my $subst = '$1db $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";