// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\[|\{)(im|tm|tv)db(?:id)?-(?:tt)?(\d+)(?:\]|\})").unwrap();
let string = "{imdb-tt0114746}
{tmdb-60948}
{tvdb-82}
[imdbid-tt0083658]
[tvdbid-356155]";
let substitution = "$1db $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}