const regex = /(?:\[|\{)(im|tm|tv)db(?:id)?-(?:tt)?(\d+)(?:\]|\})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\[|\\{)(im|tm|tv)db(?:id)?-(?:tt)?(\\d+)(?:\\]|\\})', 'gm')
const str = `{imdb-tt0114746}
{tmdb-60948}
{tvdb-82}
[imdbid-tt0083658]
[tvdbid-356155]`;
const subst = `$1db $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);