#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(js|jpg|css)\b"
Local $sString = "<img src="logo.jpg" />" & @CRLF & _
"<script src="head.js"></script> //double quotes" & @CRLF & _
"<script src='head.js'></script> //single quote" & @CRLF & _
"<link rel="stylesheet" type="text/css" href="mystyle.css">" & @CRLF & _
"<script src="head.json"></script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")