package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(js|jpg|css)\b`)
var str = `<img src="logo.jpg" />
<script src="head.js"></script> //double quotes
<script src='head.js'></script> //single quote
<link rel="stylesheet" type="text/css" href="mystyle.css">
<script src="head.json"></script>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}