use strict;
my $str = '<img src="logo.jpg" />
<script src="head.js"></script> //double quotes
<script src=\'head.js\'></script> //single quote
<link rel="stylesheet" type="text/css" href="mystyle.css">
<script src="head.json"></script>';
my $regex = qr/\b(js|jpg|css)\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}