import Foundation
let pattern = #"\b(js|jpg|css)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<img src="logo.jpg" />
<script src="head.js"></script> //double quotes
<script src='head.js'></script> //single quote
<link rel="stylesheet" type="text/css" href="mystyle.css">
<script src="head.json"></script>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)