// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(js|jpg|css)\b").unwrap();
let string = "<img src=\"logo.jpg\" />
<script src=\"head.js\"></script> //double quotes
<script src='head.js'></script> //single quote
<link rel=\"stylesheet\" type=\"text/css\" href=\"mystyle.css\">
<script src=\"head.json\"></script>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}