using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(js|jpg|css)\b";
string input = @"<img src=""logo.jpg"" />
<script src=""head.js""></script> //double quotes
<script src='head.js'></script> //single quote
<link rel=""stylesheet"" type=""text/css"" href=""mystyle.css"">
<script src=""head.json""></script>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}