const regex = /\b(js|jpg|css)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(js|jpg|css)\\b', 'g')
const str = `<img src="logo.jpg" />
<script src="head.js"></script> //double quotes
<script src='head.js'></script> //single quote
<link rel="stylesheet" type="text/css" href="mystyle.css">
<script src="head.json"></script>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}