$re = '/\b(js|jpg|css)\b/';
$str = '<img src="logo.jpg" />
<script src="head.js"></script> //double quotes
<script src=\'head.js\'></script> //single quote
<link rel="stylesheet" type="text/css" href="mystyle.css">
<script src="head.json"></script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);