# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:[^_]+_){2})(?=_)/\1ZZZ/g;t' <<< "B_502_ZZZ_01
B_400__01"