#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?:[^_]+_){2})(?=_)"
Local $sString = "B_502_ZZZ_01" & @CRLF & _
"B_400__01"
Local $sSubst = "\1ZZZ"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)