$re = '/((?:[^_]+_){2})(?=_)/';
$str = 'B_502_ZZZ_01
B_400__01';
$subst = "\1ZZZ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;